[problem log] Radio disabled by HW RF Kill switch … Karmic Koala on HP 520

Just replaced my Opensuse 11.1 with Karmic Koala. Back to Ubuntu, then. No spesific reason. New year, new distro 🙂

I got HP 520 from the office. Intel Core Duo, T2400, 1.83GHz with 2MB RAM. Not much, but considered sufficient for working. Been installed with Windows XP SP2, Mandriva 2008, Opensuse 9, BlankOn, Hardy Heron, Opensuse 11.1 and now Karmic Koala. The problems are the same … modems and wireless. But no … if I am not mistaken, the wireless was working well on Hardy.

The weird thing is somehow the wireless switch is not working in Karmic. So when the machine is booting, the LED is blinking (“blue”) and then off.  When I used dual booting with Windows, I have to go Windows systems, switch on wireless button, restart and go to Linux. What the h**l ….

Now I want this wifi to work on Karmic. According to Mr. Google, the wireless card is identified as Intel iwl3945.

dicky@isd-ubuntu:~$ sudo lshw -C network
*-network DISABLED
description: Wireless interface
product: PRO/Wireless 3945ABG [Golan] Network Connection
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:10:00.0
logical name: wmaster0
version: 02
serial: 00:1c:bf:79:87:fb
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list logical ethernet physical wireless
configuration: broadcast=yes driver=iwl3945 latency=0 multicast=yes wireless=IEEE 802.11abg
resources: irq:26 memory:f0000000-f0000fff
*-network
description: Ethernet interface
product: 82562ET/EZ/GT/GZ – PRO/100 VE (LOM) Ethernet Controller Mobile
vendor: Intel Corporation
physical id: 8
bus info: pci@0000:02:08.0
logical name: eth0
version: 01
serial: 00:1b:38:c5:39:01
size: 100MB/s
capacity: 100MB/s
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.24-k2-NAPI duplex=full firmware=N/A ip=172.27.33.77 latency=64 link=yes maxlatency=56 mingnt=8 multicast=yes port=MII speed=100MB/s
resources: irq:20 memory:f0101000-f0101fff ioport:2000(size=64)

I think the problem relates to the Kill Switch. The message logs show something interesting …

dicky@isd-ubuntu:~$ sudo cat /var/log/messages | grep switch
[sudo] password for dicky:
Jan 27 21:17:46 isd-ubuntu kernel: [    0.194293] ACPI: EC: non-query interrupt received, switching to interrupt mode
Jan 27 21:17:46 isd-ubuntu kernel: [    2.470738] Console: switching to colour frame buffer device 160×50
Jan 28 08:21:14 isd-ubuntu kernel: [    0.194511] ACPI: EC: non-query interrupt received, switching to interrupt mode
Jan 28 08:21:14 isd-ubuntu kernel: [    2.535130] Console: switching to colour frame buffer device 160×50
Jan 28 08:51:07 isd-ubuntu kernel: [    0.194014] ACPI: EC: non-query interrupt received, switching to interrupt mode
Jan 28 08:51:07 isd-ubuntu kernel: [    2.478461] Console: switching to colour frame buffer device 160×50
Jan 28 11:08:23 isd-ubuntu kernel: [    0.193782] ACPI: EC: non-query interrupt received, switching to interrupt mode
Jan 28 11:08:23 isd-ubuntu kernel: [    2.482947] Console: switching to colour frame buffer device 160×50
Jan 28 13:43:14 isd-ubuntu kernel: [    0.193665] ACPI: EC: non-query interrupt received, switching to interrupt mode
Jan 28 13:43:14 isd-ubuntu kernel: [    2.481596] Console: switching to colour frame buffer device 160×50
Jan 28 13:43:15 isd-ubuntu kernel: [   10.288701] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
Jan 28 13:43:16 isd-ubuntu kernel: [   11.126344] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch

Meaning that … yes, the switch must be turn on first. I tried to press the button and no result. Check the BIOS, and yes … it is enabled already.

Tried to search on Ubuntu forums, tried some recommendations and resulting my card was accidently removed … 😦 Somehow, this is also recorded as BUGS in ubuntu launchpad.

Well, must tried harder … keep reading and trying. Will update you about the progress.

Wish me luck!

Advertisements

2 thoughts on “[problem log] Radio disabled by HW RF Kill switch … Karmic Koala on HP 520

Add yours

  1. Any progress?
    I have HP530 with Ubuntu 10.04 and exactly the same problem. And also, I remember that on 8.04 it was working. Not sure about 8.10, but surely it didn’t work in 9.04 and 9.10.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog at WordPress.com.

Up ↑

%d bloggers like this: